Weather Services

Incident Report for EnergyCAP

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 08:49 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 14, 2025 - 13:45 EDT

Monitoring

We are currently experiencing issues with our upstream weather provider. Once weather data is received from our partner, we will backfill and reprocess affected data.
Posted Jul 14, 2025 - 10:31 EDT
This incident affected: Weather Services.