Upstream Provider Incident
Incident Report for EnergyCAP
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 11:00 EST
Update
Our fiber interconnect has been fully restored. We will continue to monitor for any further issues.

If you are experiencing issues please reach out to EnergyCAP Support at https://helpcenter.energycap.com/.
Posted Nov 18, 2023 - 12:02 EST
Update
Our upstream partners are still investigating the root cause of our fiber interconnect interruption.
Posted Nov 18, 2023 - 08:43 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2023 - 18:47 EST
Monitoring
We are currently monitoring an upstream provider incident related to our fiber interconnect. Some customers may experience degraded performance.

If you are experiencing issues please reach out to EnergyCAP Support at https://helpcenter.energycap.com/.
Posted Nov 17, 2023 - 18:07 EST
This incident affected: EnergyCAP Implementation and Bill CAPture.