Degraded Performance
Incident Report for EnergyCAP
Resolved
This incident has been resolved.
Posted Sep 24, 2023 - 21:54 EDT
Update
We are continuing to monitor for future issues.
Posted Sep 21, 2023 - 09:35 EDT
Monitoring
We continue to monitor slower than normal response times.
Posted Sep 20, 2023 - 10:41 EDT
Investigating
We are actively monitoring increased latency and slow response times. Our team is actively working to resolve the issue and restore full performance.
Posted Sep 18, 2023 - 15:54 EDT
This incident affected: EnergyCAP Enterprise, EnergyCAP Optimum, EnergyCAP FedRAMP, EnergyCAP Professional, EnergyCAP Express, EnergyCAP Express (Canada), EnergyCAP Home, EnergyCAP Consulting Platform, EnergyCAP Implementation, EnergyCAP Utility Platform, and Bill CAPture.