Degraded Performance
Incident Report for EnergyCAP
Resolved
This incident has been resolved.
Posted Nov 24, 2022 - 01:39 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 24, 2022 - 00:41 EST
Monitoring
We are currently monitoring an increase in load.
Posted Nov 24, 2022 - 00:01 EST
This incident affected: EnergyCAP Enterprise, EnergyCAP Professional, EnergyCAP Express, EnergyCAP Consulting Platform, EnergyCAP Legacy Enterprise, Bill CAPture, and Bill Images.