Data Processing Infrastructure

Incident Report for EnergyCAP

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:52 EDT

Investigating

Our data processing infrastructure is experiencing high volume. This is causing a delay in processing queued work.
Posted Mar 17, 2025 - 09:48 EDT