Investigating Security Concern
Incident Report for EnergyCAP
Resolved
This incident has been resolved. A root cause analysis will be performed to document and communicate how and why Bill CAPture was affected.

Please reach out to Support via https://helpcenter.energycap.com if you are experiencing any issues related to this incident.
Posted May 07, 2024 - 20:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 07, 2024 - 18:39 EDT
Update
We continue to investigate security concerns related to Bill CAPture. We anticipate restoration to all affected services and systems by 6-7PM ET.
Posted May 07, 2024 - 15:34 EDT
Update
The next status update will be provided around 3:30 PM ET
Posted May 07, 2024 - 14:25 EDT
Update
We continue to investigate security concerns with Bill CAPture. While there has been no indication of access to customer data, new infrastructure is being provided for Bill CAPture. We anticipate restoration to all affected services and systems today.
Posted May 07, 2024 - 13:42 EDT
Investigating
Bill CAPture has been disabled so that we can investigate a security concern. We are working diligently to restore services related to the affected systems. More information will be provided in the next update scheduled for 1:30PM ET.
Posted May 07, 2024 - 11:29 EDT
This incident affected: Bill CAPture.